shopping cart empty
WORLDWIDE FREE SHIPPING

Board gone wild!
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      9/15/2016 9:39:06 AM US Central   quote/reply + tips
balling
Member
  • JoinedApr 2014
  • Posts 396
  • Reviews 33
  • Kudos189
Board gone wild!
My Pico (bought here 3 moths ago) has gone mad!
It was set in TC but now temperature is running up and down by itself. I removed the battery and put it back with the same result. It immediately starts running to max. temp.
It also does the same act when pushing the fire button. Using + or - it locks itself. Other settings are not accessible.
Seems a severe contact or board problem. Any thoughts or does this sounds familiair?

Edited on 9/15/2016 at 9:40 AM. Reason:
#2 (permalink)      9/15/2016 9:45:49 AM US Central   quote/reply + tips
Avatar
joaopra
Member
  • JoinedSep 2013
  • Posts 4796
  • Reviews 72
  • Kudos4103
+1 details
I would say it must some issue with the + and - buttons, like they are being pressed all the time.
Did you had some leak of juice?

Try to disassemble and clean it first.
Using "regulation" as poorly disguised prohibition is criminal. Vaping is not smoking, reduces harm and saves lives.
#3 (permalink)      9/15/2016 9:57:26 AM US Central   quote/reply + tips
balling
Member
  • JoinedApr 2014
  • Posts 396
  • Reviews 33
  • Kudos189
Thanks joaopra for your advice.
I understand that there are non leaking tanks in the univers but besides that: Yes there were occasional leaks.
I'm going to dismatle and clan it.
Get back for the result.
Thanks again!
#4 (permalink)      9/15/2016 10:36:14 AM US Central   quote/reply + tips
balling
Member
  • JoinedApr 2014
  • Posts 396
  • Reviews 33
  • Kudos189
I took it apart and checked and cleaned the buttons. There were no traces of liquid visable on or around the board and inside the hull.
Put it back together and tried again: No result. Same ADHD behavior.
Buttons are clickable and are not stuck or so. Problem is that when I click a button the board starts running up to max. temp.
Same thing happens when I hit the fire button and +/- button.But it only starts running when placing a bat or pressing a button.
#5 (permalink)      9/15/2016 10:45:55 AM US Central   quote/reply + tips
Avatar
Vapor
Member
  • JoinedApr 2013
  • Posts 25007
  • Reviews 153
  • Kudos20043
Depending on your location (cost of shipping):

3 to 6 months after initial shipment of order:
Upon returning, defective items are replaced and shipped back to customers for free. Return shipping reimbursement is unavailable.

USPS Priority service is about 6 bucks for a padded envelope... That is what would be used by me as it comes with free insurance and tracking...

Edited on 9/15/2016 at 10:47 AM. Reason:
Heaven has a wall and strict immigration policies. Hell has open borders.
#6 (permalink)      9/15/2016 10:47:20 AM US Central   quote/reply + tips
Randallwhiz
Member
  • JoinedAug 2013
  • Posts 1980
  • Reviews 11
  • Kudos847
+1 details
balling wrote:

My Pico (bought here 3 moths ago) has gone mad!It was set in TC but now temperature is running up and down by itself. I removed the battery and put it back with the same result. It immediately starts running to max. temp.It also does the same act when pushing the fire button. Using + or - it locks itself. Other settings are not accessible.Seems a severe contact or board problem. Any thoughts or does this sounds familiair?



3 months of use with juice constantly in it... sounds like you did fine. What did 3 months worth of cigarettes run ya? Pour a ml of juice in your iPhone once a day & see how long it lasts. My thoughts are take care of your shit if you want it to last.

#7 (permalink)      9/15/2016 10:49:12 AM US Central   quote/reply + tips
Avatar
TorontoSteve
Member
  • JoinedNov 2013
  • Posts 951
  • Reviews 40
  • Kudos713
Sounds like you got it wet...
#8 (permalink)      9/15/2016 10:49:34 AM US Central   quote/reply + tips
Randallwhiz
Member
  • JoinedAug 2013
  • Posts 1980
  • Reviews 11
  • Kudos847
Vapor wrote:

Depending on your location (cost of shipping):

3 to 6 months after initial shipment of order:
Upon returning, defective items are replaced and shipped back to customers for free. Return shipping reimbursement is unavailable.



If OP asks for, or FT grants a full refund, then THAT is robbery.

#9 (permalink)      9/15/2016 10:49:32 AM US Central   quote/reply + tips
Randallwhiz
Member
  • JoinedAug 2013
  • Posts 1980
  • Reviews 11
  • Kudos847
+1 details
Vapor wrote:

Depending on your location (cost of shipping):

3 to 6 months after initial shipment of order:
Upon returning, defective items are replaced and shipped back to customers for free. Return shipping reimbursement is unavailable.



If OP asks for, or FT grants a full refund, then THAT is robbery. Fucking double post bullshit.


Edited on 9/15/2016 at 10:50 AM. Reason: Look away
#10 (permalink)      9/15/2016 10:51:47 AM US Central   quote/reply + tips
Avatar
jackenite
Member
  • JoinedMay 2014
  • Posts 3244
  • Reviews 125
  • Kudos3524
Just get another, sounds safer than a mech.

Naarf
It's ever only you, the object, & the opportunity for excellence.
#11 (permalink)      9/15/2016 10:54:54 AM US Central   quote/reply + tips
Avatar
Vapor
Member
  • JoinedApr 2013
  • Posts 25007
  • Reviews 153
  • Kudos20043
OP Don't you need to desolder for disassembly? I opened mine up when I first got and kinda recall desolder was the only way for a complete disassembly...
Heaven has a wall and strict immigration policies. Hell has open borders.