shopping cart empty
WORLDWIDE FREE SHIPPING

Problems with T96 Pro+
Login to post a new topic and to write a reply.
Thread Tools Rate This Thread


Search within thread:

Login to rate this thread.
#1 (permalink)      1/4/2017 12:51:58 AM US Central   quote/reply + tips
Robertb808
Member
  • JoinedMar 2014
  • Posts 4
  • Reviews 0
  • Kudos1
Problems with T96 Pro+
Received and setup the unit. Startup was fine but as soon as it got through the startup splash screen and into the main menu, the unit would say, "Powering Down" and turned itself off. Tried about 5 more times with no success, then let it sit for about 5 minutes and tried again. I was then able to get into the menu, but about 15 to 20 minutes later, it would shut itself off.
#2 (permalink)      1/4/2017 2:57:21 AM US Central   quote/reply + tips
Avatar
Anniepan
Staff
  • JoinedNov 2016
  • Posts 7651
  • Reviews 0
  • Kudos4362
+1 details
Hello Robertb808,

Sorry to hear about the issue.

The TV box need to be upgraded. I will send the software and steps to your email as soon as possible once I get the files. Thank you.
#3 (permalink)      1/4/2017 3:16:33 AM US Central   quote/reply + tips
VTEC_
Member
  • JoinedApr 2013
  • Posts 895
  • Reviews 230
  • Kudos409
Aww man, I ordered this as a slight upgrade from SKU 5612402. Hopefully This upgrade gets ya all sorted. Did you happen to notice what Version Kodi it has? Anniepan can you update us here on what this software upgrade entails?
#4 (permalink)      1/5/2017 3:21:51 AM US Central   quote/reply + tips
Avatar
Anniepan
Staff
  • JoinedNov 2016
  • Posts 7651
  • Reviews 0
  • Kudos4362
Robertb808 wrote:

Received and setup the unit. Startup was fine but as soon as it got through the startup splash screen and into the main menu, the unit would say, "Powering Down" and turned itself off. Tried about 5 more times with no success, then let it sit for about 5 minutes and tried again. I was then able to get into the menu, but about 15 to 20 minutes later, it would shut itself off.




Hello Robertb808,

I sent an message to your email address, please kindly check. Thank you.

#5 (permalink)      1/5/2017 2:06:59 PM US Central   quote/reply + tips
Robertb808
Member
  • JoinedMar 2014
  • Posts 4
  • Reviews 0
  • Kudos1
I have downloaded the tool but still need a username and password to download the file. Please send asap please. Thank you
#6 (permalink)      1/5/2017 2:19:48 PM US Central   quote/reply + tips
Avatar
ChappySinclair
Member
  • JoinedMar 2015
  • Posts 4038
  • Reviews 0
  • Kudos4781
why upgrade to these? is there much 4k or HRD content on Kodi? i've read that there's very little performance gains from the s905x vs the s912
#7 (permalink)      1/5/2017 3:53:18 PM US Central   quote/reply + tips
duckster
Member
  • JoinedApr 2015
  • Posts 28
  • Reviews 16
  • Kudos8
+1 details
ChappySinclair wrote:

why upgrade to these? is there much 4k or HRD content on Kodi? i've read that there's very little performance gains from the s905x vs the s912



For my Christmas shopping for good android tv boxes out of all the reviews, Yes there is a large jump in the Benchmark scores AnTuTu, Geekbench4, Ice Storm Extreme when using the newer S912 and T820 GPU combination. My primary areas of interest are of course good benchmarks speeds, but I wanted really good WiFi speeds also, since a wired connection is not practical for my use. I bought a MeCool BB2 Pro which has 3GB DDR4 Ram and 16GB Rom and decent but not the very best WiFi, also considered the Yoka KB2 Pro also 3GB DDR4 Ram and 32GB Rom, but at $30 more not worth it to get extra 16GB Rom, when I have bought 32GB sd for $7 each. These units are identical with different Names only, the reviewer "Redskull" found no appreciable video performance increase due to the extra Ram although it has faster read and write speeds due to it being DDR4 vs DDR3. This reviewer is very consistent in the order of, and type of information given, so it is easy to compare different models. Example review https://www.youtube.com/watch?v=UWn4bGurD3A He really likes even better than the model I picked, and probably less cost the MXIII-G-II. I also have to be concerned that boxes are 2.4Ghz and 5.0Ghz and not 2.4Ghz and 5.8Ghz which will not work in the Unites States of America. Kodi 17.0 still problematic need to reload Jarvis 16.0 if box comes with Kodi 17.0

#8 (permalink)      1/7/2017 2:52:08 AM US Central   quote/reply + tips
Trmn8rharley
Member
  • JoinedMay 2015
  • Posts 3
  • Reviews 0
  • Kudos0
Robertb808 wrote:

Received and setup the unit. Startup was fine but as soon as it got through the startup splash screen and into the main menu, the unit would say, "Powering Down" and turned itself off. Tried about 5 more times with no success, then let it sit for about 5 minutes and tried again. I was then able to get into the menu, but about 15 to 20 minutes later, it would shut itself off.


Did you get the problem fixed? I just purchased one and it hasn't shipped yet

#9 (permalink)      1/7/2017 2:54:04 AM US Central   quote/reply + tips
Trmn8rharley
Member
  • JoinedMay 2015
  • Posts 3
  • Reviews 0
  • Kudos0
What was the upgrade you were sent?
#10 (permalink)      1/7/2017 3:13:44 AM US Central   quote/reply + tips
Trmn8rharley
Member
  • JoinedMay 2015
  • Posts 3
  • Reviews 0
  • Kudos0
Was it a firmware upgrade I'm guessing? There is a sight called Chinese gadgets review that has firmware upgrades. Did you have to download the burner and plug USB into computer then while installing USB into box use a toothpick to reset then burn new firmware? Sort of like doing a router.
#11 (permalink)      1/7/2017 5:55:51 AM US Central   quote/reply + tips
BarraEdinazzu
Member
  • JoinedAug 2013
  • Posts 16
  • Reviews 96
  • Kudos5
Is your T96 Pro+ connected thru hdmi?
Check the settings on your tv and or reciever, turn of the hdmi thru mode and check your cec settings.
Hopfully solve your problem for now.